RSS

Blokir Situs Pada Jam Tertentu Menggunakan MikroTik

29 Jan
Kali ini sya akan melanjutkan bahasan sebelumnya mengenai MikroTik, yaitu Cara Memblokir Situs Pada Jam Tertentu, . . .
Silakn copy kan script yang berwarna hijau pada terminal winbox Anda, .
Pertama, supaya waktu yang berjalan di router sesuai dengan waktu lokasi setempat, maka kita perlu mengatur agar clock di MikroTik mengacu pada NTP Server. Jika kita memiliki NTP Server sendiri, maka kita tinggal mengarahkan MikroTik ke NTP Server tersebut, namun jika kita tidak memiliki NTP Server, maka tidak perlu khawatir karena banyak NTP Server di luar yang bisa kita gunakan sebagai acuan. Beberapa diantaranya adalah NTP Server milik LIPI (Lembaga Ilmu Pengetahuan Indonesia) dengan URL: ntp.kim.lipi.go.id (203.160.128.6) dan NTP Pool Project dengan salah satu URLnya: 0.id.pool.ntp.org (202.169.224.16). Untuk mensettingnya di MikroTik, ketikkan perintah berikut :
/system ntp client set primary-ntp=203.160.128.6 secondary-ntp=202.169.224.16 \ mode=unicast enabled=yes;
Kedua, membuat rule di firewall filter. Dalam hal ini saya ingin memblokir situs Facebook yang menggunakan port HTTP (80), sehingga selain port tersebut masih diijinkan. Tujuannya agar pengguna masih dapat menerima update status facebook melalui email. Untuk mensettingnya ketikkan perintah berikut :
/ip firewall filter add chain=forward src-address=0.0.0.0/0 protocol=tcp \ dst-port=80 content=”facebook” action=drop comment=”Blokir Akses Facebook”;
Ketiga, membuat script untuk mengaktifkan firewall tersebut selama jam kerja dan mematikannya pada jam istirahat dan diluar jam kerja. Disini saya membuat 3 script, yaitu script untuk mengaktifkan  (enable) firewall, script untuk mematikan (disable) firewall serta script untuk dieksekusi pada hari libur (Sabtu-Minggu) dan hari kerja. Berikut ini scriptnya :
Script untuk mematikan (disable) firewall :
/system script add name=”fb-allow” policy=write,read,policy,test source={/ip firewall filter set [/ip firewall filter find content=”facebook”] disabled=yes}
Script untuk mengaktifkan (enable) firewall :
/system script add name=”fb-deny” policy=write,read,policy,test source={/ip firewall filter set [/ip firewall filter find content=”facebook”] disabled=no}
Script untuk disable firewall di hari libur dan enable di hari kerja :
/system script add name=”fb-holiday” policy=write,read,policy,test source={:if ([/system scheduler get [/system scheduler find on-event=”fb-deny”] disabled] = true) do [/system scheduler set [/system scheduler find on-event=”fb-deny”] disabled=no] else [/system scheduler set [/system scheduler find on-event=”fb-deny”] disabled=yes]}
Keempat, membuat schedule untuk menentukan kapan firewall tersebut akan diaktifkan atau dinon-aktifkan. Disini saya membuat 6 scheduler berdasarkan jam kerja dan hari kerja, yaitu jam 08:00, jam 12:00, jam 13:00, jam 17:00, hari sabtu-minggu, dan hari senin. Berikut ini scriptnya :
Schedule untuk mengaktifkan (enable) firewall pada jam kerja (08:00) :
/system scheduler add name=”fb-08:00″ start-date=jan/01/1970 start-time=08:00:00 interval=1d on-event=”fb-deny”
Schedule untuk mematikan (disable) firewall pada jam istirahat (12:00) :
/system scheduler add name=”fb-12:00″ start-date=jan/01/1970 start-time=12:00:00 interval=1d on-event=”fb-allow”
Schedule untuk mengaktifkan kembali (enable) firewall pada jam kerja (13:00) :
/system scheduler add name=”fb-13:00″ start-date=jan/01/1970 start-time=13:00:00 interval=1d on-event=”fb-deny”
Schedule untuk mematikan (disable) firewall di luar jam kerja ke atas ( > 17:00) :
/system scheduler add name=”fb-17:00″ start-date=jan/01/1970 start-time=17:00:00 interval=1d on-event=”fb-allow”
Schedule untuk mematikan (disable) firewall di hari libur (Sabtu-Minggu) :
/system scheduler add name=”fb-sabtu-minggu” start-date=aug/01/2009 start-time=00:00:00 interval=7d on-event=”fb-holiday”
Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler adalah Hari Sabtu. Dan parameter “interval” diberi nilai 7d.
Schedule untuk mengaktifkan kembali (enable) firewall di hari kerja (Senin) :
/system scheduler add name=”fb-senin” start-date=aug/03/2009 start-time=00:00:00 interval=7d on-event=”fb-holiday”
Pastikan bahwa tanggal yang didefinisikan pada parameter “start-date” scheduler adalah Hari Senin. Dan parameter “interval” diberi nilai 7d.
Iklan
 
6 Komentar

Ditulis oleh pada 29 Januari 2012 in MikroTik, Tips and Trick, TKJ

 

Tag: , , ,

6 responses to “Blokir Situs Pada Jam Tertentu Menggunakan MikroTik

  1. bubbleshooter2.info

    20 Maret 2012 at 10:41 AM

    Wonderful article, I will bookmark Blokir Situs Pada Jam Tertentu Menggunakan MikroTik Dunia Open Source Linux.

     
  2. Starship Eleven at bigfreeonlinegames

    25 Maret 2012 at 4:05 PM

    Blokir Situs Pada Jam Tertentu Menggunakan MikroTik Gerakan Open Source is a wonderful posting. I am going to spend more time researching this topic.

     
  3. Jocuri sniper

    5 April 2012 at 10:02 AM

    Interesting material, thank you for sharing them in Blokir Situs Pada Jam Tertentu Menggunakan MikroTik Gerakan Open Source.

     
  4. Arsad Arposid

    14 Mei 2012 at 2:21 PM

    kalau kita mempunyai beberapa default gatway dan hanya satu gatway saja yg bisa kita block gimana caranya ya??bisa jawabannya kirim ke email saya ya “arsad_pisces@yahoo.com”

     
  5. hendri

    14 Desember 2012 at 12:53 AM

    klau port 80 di blokir maka semua browsing ya kena blokir lah mas…. bukannya facebook doank kena blokir malah semua browsing kena blokir

     
  6. khoiciro

    4 Maret 2014 at 2:54 PM

    klo mau merubah schedule nya gman gan,,?

     

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

 
%d blogger menyukai ini: