RSS

Vyatta: VLAN

29 Mei

Skenario:

vlanvyatta

Dari gambar di atas, ada 3 vlan yang dikonfigurasi pada switch catalyst 2950, yaitu vlan 101, 102, 103. Network dari keanggotaan vlan tersebut adalah sebagai berikut:

vlan 101 : 192.168.101.0/24 ; gateway:192.168.101.254
vlan 102 : 192.168.102.0/24 ; gateway:192.168.102.254
vlan 103 : 192.168.103.0/24 ; gateway:192.168.103.254
Sedangkan vlan 1 (administrative) diset IP-nya 10.10.10.1/24 dengan gateway 10.10.10.254.

Penempatan port untuk keanggotaan vlan telah ditentukan, dimana port fa0/9 pada vlan 101, port fa0/10 pada vlan 102 dan port fa0/11 pada vlan 103. Dan port fa0/12 merupakan Trunk Link yang terhubung ke eth0 vyatta.

Untuk implementasi skenario di atas maka konfigurasi switch catalyst 2950 adalah sebagai berikut:

Switch>enable
Switch#config t
Swtich(config)#hostname C2950
C2950(config)#enable secret en_c2950
C2950(config)#line vty 0 15
C2950(config-line)#password telnet_c2950
C2950(config-line)#login
C2950(config-line)#interface vlan1
C2950(config-if)#ip address 10.10.10.1 255.255.255.0
C2950(config-if)#no shutdown
C2950(config-if)#exit
C2950(config)#ip default-gateway 10.10.10.254
C2950(config)#exit
C2950#vlan database
C2950(vlan)#vlan 101 name vlan_101
C2950(vlan)#vlan 102 name vlan_102
C2950(vlan)#vlan 103 name vlan_103
C2950(vlan)#apply
C2950(vlan)#exit
C2950#config t
C2950(config)#interface fa0/12
C2950(config-if)#description trunk link ke vyatta
C2950(config-if)#switchport mode trunk
C2950(config-if)#interface fa0/11
C2950(config-if)#description vlan_103
C2950(config-if)#switchport access vlan 103
C2950(config-if)#interface fa0/10
C2950(config-if)#description vlan_102
C2950(config-if)#switchport access vlan 102
C2950(config-if)#interface fa0/9
C2950(config-if)#description vlan_101
C2950(config-if)#switchport access vlan 101
C2950(config-if)#end
C2950#copy running-config startup-config
C2950#

Konfigurasi interface eth0 Vyatta sebagai vlan adalah:

vyatta@vyatta$configure
vyatta@vyatta#set interfaces ethernet eth0 address 10.10.10.254/24
vyatta@vyatta#set interfaces ethernet eth0 vif 101 address 192.168.101.254/24
vyatta@vyatta#set interfaces ethernet eth0 vif 102 address 192.168.102.254/24
vyatta@vyatta#set interfaces ethernet eth0 vif 103 address 192.168.103.254/24
vyatta@vyatta#commit
vaytta@vyatta#save
vyatta@vyatta#

Iklan
 
Tinggalkan komentar

Ditulis oleh pada 29 Mei 2011 in CentOS

 

Tag:

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

 
%d blogger menyukai ini: