RSS

Pfsense: VLAN

29 Mei

Skenario:

vlanpfsense

Dari gambar di atas, ada 3 vlan yang dikonfigurasi pada switch catalyst 2950, yaitu vlan 101, 102, 103. Network dari keanggotaan vlan tersebut adalah sebagai berikut:

vlan 101 : 192.168.101.0/24 ; gateway:192.168.101.1
vlan 102 : 192.168.102.0/24 ; gateway:192.168.102.1
vlan 103 : 192.168.103.0/24 ; gateway:192.168.103.1
Sedangkan vlan 1 (administrative) diset IP-nya 192.168.3.2/24 dengan gateway 192.168.3.1

Penempatan port untuk keanggotaan vlan telah ditentukan, dimana port fa0/9 pada vlan 101, port fa0/10 pada vlan 102 dan port fa0/11 pada vlan 103. Dan port fa0/12 merupakan Trunk Link yang terhubung ke eth0 pfsense.

Untuk implementasi skenario di atas maka konfigurasi switch catalyst 2950 adalah sebagai berikut:

Switch>enable
Switch#config t
Swtich(config)#hostname C2950
C2950(config)#enable secret en_c2950
C2950(config)#line vty 0 15
C2950(config-line)#password telnet_c2950
C2950(config-line)#login
C2950(config-line)#interface vlan1
C2950(config-if)#ip address 192.168.3.2 255.255.255.0
C2950(config-if)#no shutdown
C2950(config-if)#exit
C2950(config)#ip default-gateway 192.168.3.1
C2950(config)#exit
C2950#vlan database
C2950(vlan)#vlan 101 name vlan_101
C2950(vlan)#vlan 102 name vlan_102
C2950(vlan)#vlan 103 name vlan_103
C2950(vlan)#apply
C2950(vlan)#exit
C2950#config t
C2950(config)#interface fa0/12
C2950(config-if)#description trunk link ke pfsense
C2950(config-if)#switchport mode trunk
C2950(config-if)#interface fa0/11
C2950(config-if)#description vlan_103
C2950(config-if)#switchport access vlan 103
C2950(config-if)#interface fa0/10
C2950(config-if)#description vlan_102
C2950(config-if)#switchport access vlan 102
C2950(config-if)#interface fa0/9
C2950(config-if)#description vlan_101
C2950(config-if)#switchport access vlan 101
C2950(config-if)#end
C2950#copy running-config startup-config
C2950#

Konfigurasi interface eth0(rl1) Pfsense sebagai vlan adalah:
akses ke pfsense, lalu pilih menu Interfaces->assign, selanjutnya klik VLAN dan terus klik tombol +. Pilihlah Parent interface, isikan VLAN tag dan description, lalu klik Save, seperti gambar di bawah ini:

lakulan lagi untuk VLAN tag 102 dan 103. lengkapnya seperti gambar di bawah ini:

berikutnya reboot.

Login lagi ke pfsense lalu pilih akses ke menu Interfaces->assign, selanjutnya pada jendela interface assignments disisi kanan bawah ada tombol + , kliklah tombol + tersebut untuk mengaktifkan interface VLAN tag 101,102 dan 103) dan klik tombol save.

langkah selanjutnya edit-lah interface tersebut dengan mengganti description dari OPT? menjadi VLAN101 dan VLAN102 dan VLAN103 beserta IP Address-nya dengan mengakses menu interfaces->OPT? seperti gambar di bawah ini:

dan klik tombol save.

 
1 Komentar

Ditulis oleh pada 29 Mei 2011 in CentOS

 

Tag:

One response to “Pfsense: VLAN

  1. pcteori

    4 Juni 2012 at 3:00 PM

    aye

     

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

 
%d blogger menyukai ini: