RSS

Dasar-dasar CLI Vyatta VC4.0.2

29 Mei

Sistem Vyatta

A. Mode CLI

Mode CLI dalam sistem Vyatta terbagi atas dua, yaitu mode operasional dan mode konfigurasi. Pada mode operasional ditunjukkan dalam bentuk :~$ dan dalam mode konfigurasi # . Jika misalkan user dengan nama vyatta login, dan terlihat prompt nya seperti berikut: vyatta@Router:~$ , maka artinya vyatta=user id ; Router=nama host ; :~$=mode operasional. dan jika prompt yang ditampilkan seperti vyatta@Router# , maka artinya vyatta=user id ; Router=nama host ; #=mode konfigurasi.

Untuk pindah dari mode operasional ke mode konfigurasi digunakan perintah configure , contoh:

vyatta@Router:~$ configure
[edit]
vyatta@Router#

Untuk keluar dari mode konfigurasi (kembali ke mode operasional) digunakan perintah exit , contoh:

vyatta@Router# exit
exit
vyatta@Router:~$

B. Pengguna

Dalam sistem vyatta pengguna dikelompokkan atas Admin dan Operator. Pada awal sistem vyatta di instalasi telah terdapat dua pengguna terdaftar sebagai Admin yaitu root dan vyatta. Perbedaan antara Admin dan Operator adalah pengguna Operator hanya dapat menjalankan perintah-perintah operasional dan tidak dapat melakukan proses konfigurasi, akan tetapi dapat melihat konfigurasi yang telah terdapat pada sistem vyatta.

CLI Berdasarkan Kebutuhan Konfigurasi

Catatan: Untuk mengkonfirmasi setiap konfigurasi yang dilakukan digunakan perintah commit. Untuk menyimpan hasil konfigurasi agar digunakan oleh sistem vyatta pada saat booting, digunakan perintah save. Untuk membatalkan proses konfigurasi yang telah dilakukan dan sekaligus keluar dari mode konfigurasi digunakan perintah exit discard.

Perintah di bawah ini menggunakan user id vyatta(sebagai Admin) dan nama host vyatta.

1. Berhubungan dengan Pengguna

:: Menambah Pengguna sebagai Admin:

vyatta@vyatta# set system login user user-name level admin
vyatta@vyatta# set system login user user-name authentication plaintext-password password
vyatta@vyatta# commit

:: Menambah Pengguna sebagai Operator:

vyatta@vyatta# set system login user user-name level operator
vyatta@vyatta# set system login user user-name authentication plaintext-password password
vyatta@vyatta# commit

:: Merubah password Pengguna:

vyatta@vyatta# set system login user user-name authentication plaintext-password new_password
vyatta@vyatta# commit

:: Menghapus Pengguna:

vyatta@vyatta# delete system login user user-name
vyatta@vyatta# commit

2. Berhubungan dengan Interface Ethernet

:: Menampilkan konfigurasi semua Interface Ethernet:

vyatta@vyatta# show interfaces

:: Menampilkan konfigurasi Interface Ethernet tertentu, misalkan eth0:

vyatta@vyatta# show interfaces ethernet eth0

:: Mengkonfigurasi Interface Ethernet, misalkan eth0 (192.168.1.1 subnet mask 255.255.255.0):

vyatta@vyatta# set interfaces ethernet eth0 address 192.168.1.1/24

:: Membuat deskripsi pada Interface Ethernet, misalkan pada eth0:

vyatta@vyatta# set interfaces ethernet eth0 description “Office LAN”

:: Menghapus konfigurasi Interface Ethernet, misalkan eth0:

vyatta@vyatta# delete interfaces ethernet eth0 address 192.168.1.1/24

3. Berhubungan dengan Host

:: Membuat Nama Host:

vyatta@vyatta# set system host-name nama-host

:: Membuat Nama Domain:

vyatta@vyatta# set system domain-name nama-domain

:: Membuat akses ke DNS Server:

vyatta@vyatta# set system name-server ip-dns

:: Membuat akses ke Gateway:

vyatta@vyatta# set system gateway-address ip-gateway

Contoh:

vyatta@vyatta# set system host-name vyatta

vyatta@vyatta# set system domain-name pnp.lan

vyatta@vyatta# set system name-server 192.168.1.254

vyatta@vyatta# set system gateway-address 192.168.1.1

4. Berhubungan dengan DHCP Server:

:: Membuat konfigurasi DHCP:

vyatta@vyatta# set service dhcp-server shared-network-name nama-network subnet sub-network start ipdhcp-awal stop ipdhcp-akhir

vyatta@vyatta# set service dhcp-server shared-network-name nama-network subnet sub-network default-router ip-gateway

vyatta@vyatta# set service dhcp-server shared-network-name nama-network subnet sub-network dns-server ip-dns

Contoh:

vyatta@vyatta# set service dhcp-server shared-network-name LANnet subnet 192.168.1.0/24 start 192.168.1.10 stop 192.168.1.250

vyatta@vyatta# set service dhcp-server shared-network-name LANnet subnet 192.168.1.0/24 default-router 192.168.1.1

vyatta@vyatta# set service dhcp-server shared-network-name LANnet subnet 192.168.1.0/24 dns-server 192.168.1.254

5. Berhubungan dengan NAT:

:: Membuat konfigurasi NAT:

vyatta@vyatta# set service nat rule rule-num source address sub-network

vyatta@vyatta# set service nat rule rule-num outbound-interface nama-interface

vyatta@vyatta# set service nat rule rule-num type masquerade

Contoh:

eksternal interface eth0 dan internal interface eth1(dengan network 192.168.1.0/24)

vyatta@vyatta# set service nat rule 1 source address 192.168.1.0/24

vyatta@vyatta# set service nat rule 1 outbound-interface eth0

vyatta@vyatta# set service nat rule 1 type masquerade

6. Berhubungan dengan Protocol Routing Statis:

:: Membuat konfigurasi Default Route:

vyatta@vyatta# set protocols static route 0.0.0.0/0 next-hop ipnexthop

:: Membuat konfigurasi Routing Statis:

vyatta@vyatta# set protocols static route net-dest next-hop ipnexthop

 
Tinggalkan komentar

Ditulis oleh pada 29 Mei 2011 in CentOS

 

Tag:

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

 
%d blogger menyukai ini: